2017年11月04日

インターネットに繋がらなくなる。原因はDHCP?

NTTのルータ(ONU)=PR-500KIにSC-40NE2の無線カードを挿して使っているのですが、9月中旬頃から1日~2日の間に、インターネットへの接続が予告なしに切断される事象が続きました。(時間帯もバラバラなので輻輳ではない)

これは、有線LAN接続だけでなく、無線LAN接続も同じ事象。もちろん、スマホのWiFiも同様です。
画面のタスクバーのアイコン表示ですが、有線ネットワークのアイコンには、黄色い!マーク。無線の方も黄色のマーク。つまり、赤の×マークではないのです。(このことに早く気づけばよかったかも?)

1.まずは、ルータに疑いをかけ、NTTに電話して取り替えたが、症状は変わらず。
(これだけでも色々な設定等で1日程度かかった)
2.次にDNSに疑いをかけ、ルータのDNS設定をプロバイダ指定の固定IPアドレスに変えた。
3.しばらくは良かったが、また当初の事象が発生し始めた。
4.コマンドプロンプトから、ipconfig /renew 等のルータのお掃除コマンドも試みたが無駄。
    それと、Flet's 光には IPv6 フォールバック問題があるとのことで、IPv6を無効にする。(ルータ側も設定)

無題2

5.有線LANアダプターのUSB版を購入して切り替えてみたが、これも徒労に終わる。
6.1日~2日の間に一回、ルータの「再起動」ボタンを押すことが1カ月近くも続いたので、我慢できなくなって、NTTに来てもらった。
7.しかし、原因はわからないままだった。プロバイダー側の問題かも?というけど・・・
ただ、「静的IPアドレスを試す」=DHCP機能を使用しない設定があるということをヒントにもらった。
8.このあと、切断された状態が発生したとき、別の無線PCからインターネットには繋がっていないものの家の中の他のネットワークには繋がっていることが判明した。つまり、ルータまでは繋がっているということだ。
一方で、DNSまでの pingは飛ばないまま。
9.ということから、これは、ローカルのIPアドレス付与(つまり、DHCP機能)がうまく行っていないのでは?という結論にたどり着いた。無題1

10.インターネットが見れない状態で、有線LANアダプターのIPv4に静的IPアドレスを振ってみたら、見事にインタネットにつながったのである。いやぁ、すっきりしたなぁもぉ・・・
(何かの後みたい??)
11.無線接続のPCにも静的IPアドレスを振り、スマホも設定がしにくかったけど、対象のSSIDに静的IPアドレスを振って、接続完了。(NASサーバーも設定しなおしたので、計7台程設定したことになる)
12.念のため、ルータの再起動をしてみたが、異常なし。

※いちいち、静的IPアドレスを振るのは面倒ですが、一度設定しておけばよく、度々切断されるよりはマシだとの思いです。
※DHCPの持続時間の設定も0(無期限)にしてみる価値はあるかも?
あるいは、ルータ側のDHCP設定でMACアドレスを使って、先に静的IPアドレスを設定してみるのもアリ?かもですが、今はやめときます。疲れました・・・



jujucall at 17:26コメント(0) |   mixiチェック

コメントする

名前
 
  絵文字
 
 
プロフィール

Mitchan

ギャラリー
  • ありがとう #57 Mitchan Live
  • 久しぶりの大阪 はじめての大阪
  • 久しぶりの大阪 はじめての大阪
  • 久しぶりの大阪 はじめての大阪
  • Mitchan Live in 門司港 Vol.57
  • 電気代のこと
  • 携帯の電話帳VCFファイルのデータ加工・・・ つれづれなるままに
  • 感謝!! Live #56
  • 感謝!! Live #56